New Site

Clearly my previous site was having performance issues.  Last night it took over 15 seconds to load this site and that had been going on for over a month.  I wasn’t on any free service either, it was ~100$ a year.

My provider, iPower asked me to make a few changes.  After about 12 ticket exchanges, the answer I finally had was that I was on a shared infrastructure and if I wan’t good service, I had to pay 100$ per month to get on a dedicated VM. That is one of the dumbest things I have ever heard of in my life.  I had been with them for about 5 years now and up until that message, I would have recommended them to others.  Today though, we’re in 2012 and everyone should be on a service managed VM.  It probably didn’t help their case that I work with that stuff on a daily basis.

So here I am, hosted by WordPress (it made sense since I used the program already) and we’ll see how this works out.

One thought on “New Site

  1. I agree, 200$ a year to be on a dedicated VM for a Blog type site, is totally ridiculous. If they treat all their clients that way, they may not have any left by next year.

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s